6to4 on a Cisco

Erik Rietberg erietberg@chello.nl
Wed, 24 Jan 2001 18:46:09 +0100


> > I think the problem is with issue 2, because I can normally ping the
> router.
> > Is the automatic IPv6-in-IPv4 tunneling a feature I can activate on a
> Cisco ??

With automatic IPv6-in-IPv4 tunneling activated on the Cisco, the Microsoft
6to4cfg works fine !

<>
C:\>6to4cfg -R sixco.ipv6.test.nl
Probing 6to4 relay router 213.x.x.x...
Found 6to4 relay router sixco.ipv6.test.nl (213.x.x.x)...
Using local address 213.x.x.x for the 6to4 prefix.
<>

For all who are interested below my current Cisco-config, with automatic
IPv6-in-IPv4 tunneling and 6to4 enabled:

<>
version 12.1
no service single-slot-reload-enable
service nagle
no service pad
service tcp-keepalives-in
service timestamps debug datetime
service timestamps log datetime
service password-encryption
!
hostname Sixco
!
boot system tftp://212.x.x.x/c3620-is-mz.20001101
logging buffered 4096 debugging
no logging rate-limit
enable secret 5 $1$ihP$wCvwdUvT6COQlmYA68ckZg/
!
ip subnet-zero
ip cef
!
!
no ip finger
ip domain-name ipv6.test.nl
ip name-server 212.x.x.x
!
no ip bootp server
ipv6 unicast-routing
call rsvp-sync
!
interface Loopback0
 no ip address
 ipv6 address 2002:XXXX:XXXX:0:10:7B15:9881:C/64
 ipv6 mtu 1480
!
interface Loopback100
 no ip address
 ipv6 address 3FFE:XXXX::1/128
 ipv6 mtu 1480
!
interface Tunnel0
 description Used for 6to4 translations
 no ip address
 no ip redirects
 no ip route-cache cef
 ipv6 enable
 ipv6 unnumbered Loopback0
 tunnel source Loopback0
 tunnel mode ipv6ip 6to4
 tunnel path-mtu-discovery
!
interface Tunnel1
 description "to IPng"
 no ip address
 no ip route-cache cef
 ipv6 enable
 ipv6 address 3FFE:XXXX::X/127
 ipv6 rip T0 enable
 tunnel source Ethernet0/0
 tunnel destination 212.19.192.219
 tunnel mode ipv6ip
!
interface Tunnel2
 description "to Laptop"
 no ip address
 ipv6 enable
 ipv6 address 3FFE:XXXX::2/127
 ipv6 rip T0 enable
 tunnel source Ethernet0/0
 tunnel destination 213.x.x.x
 tunnel mode ipv6ip
!
interface Tunnel3
 description "automatic tunneling"
 no ip address
 no ip redirects
 no ip route-cache cef
 tunnel source Ethernet0/0
 tunnel mode ipv6ip auto-tunnel
!
interface Ethernet0/0
 ip address 213.x.x.x 255.255.255.224
 no ip redirects
 no ip proxy-arp
 ip mtu 1480
 ip route-cache flow
 half-duplex
 ipv6 enable
!
interface Serial0/0
 no ip address
 shutdown
!
interface Serial0/1
 no ip address
 shutdown
!
interface Ethernet1/0
 no ip address
 shutdown
 half-duplex
!
router bgp 100
 no synchronization
 no bgp default ipv4-unicast
 bgp log-neighbor-changes
 !
 address-family ipv6
 network DEAD::/64
 exit-address-family
!
ip classless
ip route 0.0.0.0 0.0.0.0 213.x.x.1
no ip http server
!

access-list 1 permit 213.x.x.x
ipv6 route 3FFE:XXXX::/60 Null0 200
ipv6 route 3FFE:XXXX::/64 Tunnel2
ipv6 route ::/0 Tunnel1
!
ipv6 access-list vty_in permit 3FFE:XXXX::1/128
!
ipv6 router rip T0
ipv6 router rip T1
!
!
dial-peer cor custom
!
!
!
!
line con 0
 login
 transport input none
line aux 0
 login
line vty 0 4
 access-class 1 in
 timeout login response 0
 ipv6 access-class vty_in in
 login
 escape-character 27
!
ntp clock-period 17179992
ntp server 212.x.x.x
end
<>

greetings,
Erik