IPv6 over IPv4 tunnels in IOS

Stefan.Gasteiger@Gendorf.de Stefan.Gasteiger@Gendorf.de
Mon, 29 May 2000 07:08:39 +0200


Hi Kristopher,

Here's an example configuration with some bgp peerings.
It would be better to use a loopback interface as 
tunnel source, so that the tunnel would still be
up, when the ethernet's down.

I'm also not sure, if the prefix-lists are 
the best thing to do (le 128).

Comments are welcome!

<---snipp--->
version 12.0
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname 6bone
!
enable secret 5 XXXXXXXXXXXXXXX
!
!
!
!
!
ip subnet-zero
ip domain-name gendorf.net
ip name-server 212.68.96.75
!
!
!
interface Tunnel0
 description Tunnel to JOIN (www.join.uni-muenster.de)
 no ip address
 no ip directed-broadcast
 ipv6 address 3FFE:401:0:1::5:2/112
 tunnel source Ethernet0
 tunnel destination 128.176.191.66
 tunnel mode ipv6ip
!
interface Tunnel1
 description Tunnel to regio.net
 no ip address
 no ip directed-broadcast
 ipv6 address 3FFE:3500:100::11/126
 tunnel source Ethernet0
 tunnel destination 212.218.0.9
 tunnel mode ipv6ip
!
interface Tunnel2
 description Tunnel zur Uni Erlangen
(erich.meier@informatik.uni-erlangen.de)
 no ip address
 no ip directed-broadcast
 ipv6 address 3FFE:400:50:200::2:2/112
 tunnel source Ethernet0
 tunnel destination 131.188.34.2
 tunnel mode ipv6ip
!
interface Tunnel3
 description Tunnel zur Uni Leipzig (toenjes@informatik.uni-leipzig.de)
 no ip address
 no ip directed-broadcast
 ipv6 address 3FFE:400:280:F001::1A/126
 tunnel source Ethernet0
 tunnel destination 139.18.38.71
 tunnel mode ipv6ip
!
interface Tunnel4
 description Tunnel zu Fibertel (platini@fibertel.com.ar)
 no ip address
 no ip directed-broadcast
 ipv6 address 3FFE:3800::A:2/112
 tunnel source Ethernet0
 tunnel destination 24.232.1.5
 tunnel mode ipv6ip
!
interface Ethernet0
 ip address 212.68.96.114 255.255.255.252
 no ip directed-broadcast
 media-type 10BaseT
 ipv6 address 3FFE:400:3B0::CFF:EE1A:AB19/80
!
interface Ethernet1
 no ip address
 no ip directed-broadcast
 shutdown
!
router bgp 12853
 no synchronization
 bgp dampening
 neighbor 3FFE:400:50:200::2:1 remote-as 1275
 no neighbor 3FFE:400:50:200::2:1 activate
 neighbor 3FFE:400:280:F001::19 remote-as 1275
 no neighbor 3FFE:400:280:F001::19 activate
 neighbor 3FFE:401:0:1::5:1 remote-as 1275
 no neighbor 3FFE:401:0:1::5:1 activate
 neighbor 3FFE:3500:100::10 remote-as 8319
 no neighbor 3FFE:3500:100::10 activate
 neighbor 3FFE:3800::A:1 remote-as 10318
 no neighbor 3FFE:3800::A:1 activate
 !
 address-family ipv6
 neighbor 3FFE:400:50:200::2:1 activate
 neighbor 3FFE:400:50:200::2:1 override-capability-neg
 neighbor 3FFE:400:50:200::2:1 prefix-list JOIN in
 neighbor 3FFE:400:50:200::2:1 prefix-list erlangen-out out
 neighbor 3FFE:400:280:F001::19 activate
 neighbor 3FFE:400:280:F001::19 override-capability-neg
 neighbor 3FFE:400:280:F001::19 prefix-list JOIN in
 neighbor 3FFE:400:280:F001::19 prefix-list leipzig-out out
 neighbor 3FFE:401:0:1::5:1 activate
 neighbor 3FFE:401:0:1::5:1 override-capability-neg
 neighbor 3FFE:401:0:1::5:1 prefix-list FULL in
 neighbor 3FFE:401:0:1::5:1 prefix-list join-out out
 neighbor 3FFE:3500:100::10 activate
 neighbor 3FFE:3500:100::10 override-capability-neg
 neighbor 3FFE:3500:100::10 prefix-list FULL in
 neighbor 3FFE:3500:100::10 prefix-list regio-out out
 neighbor 3FFE:3800::A:1 activate
 neighbor 3FFE:3800::A:1 override-capability-neg
 neighbor 3FFE:3800::A:1 prefix-list FULL in
 neighbor 3FFE:3800::A:1 prefix-list fibertel-out out
 network 3FFE:400:3B0::/48
 network 3FFE:3500:100::/48
 aggregate-address 3FFE:400:3B0::/48
 aggregate-address 3FFE:3500:100::/48
 exit-address-family
!
ip default-gateway 212.68.96.113
ip classless
ip route 0.0.0.0 0.0.0.0 212.68.96.113
no ip http server
!
!
ip prefix-list FULL seq 5 permit 3FFE::/16 le 128
ip prefix-list FULL seq 10 permit 2001::/16 le 128
ip prefix-list FULL seq 15 permit 2002::/16 le 128
!         
ip prefix-list JOIN seq 5 permit 3FFE:400::/24 le 128
!
ip prefix-list erlangen-out seq 5 permit 3FFE:400:3B0::/48 le 128
ip prefix-list erlangen-out seq 10 permit 3FFE:3500:100::/48 le 128
ip prefix-list erlangen-out seq 15 permit 3FFE:400:180::/48 le 128
ip prefix-list erlangen-out seq 20 permit 3FFE:400:280::/48 le 128
!
ip prefix-list fibertel-out seq 5 deny ::/0 le 128
!
ip prefix-list join-out seq 5 permit 3FFE:400:50::/48 le 128
ip prefix-list join-out seq 10 permit 3FFE:400:180::/48 le 128
ip prefix-list join-out seq 15 permit 3FFE:400:280::/48 le 128
ip prefix-list join-out seq 20 permit 3FFE:400:3B0::/48 le 128
!
ip prefix-list leipzig-out seq 5 permit 3FFE:400:3B0::/48 le 128
ip prefix-list leipzig-out seq 10 permit 3FFE:3500:100::/48 le 128
ip prefix-list leipzig-out seq 15 permit 3FFE:400:50::/48 le 128
!
ip prefix-list regio-out seq 5 permit 3FFE:3500:100::/48 le 128
!
!
line con 0
 transport input none
line aux 0
line vty 0 4
 password 7 XXXXXXXXXXXXXXX
 login
!
end
<---snipp--->

Kind regards,
 
Stefan Gasteiger
SG5599-RIPE
I+K Betrieb (zertifiziert nach DIN EN ISO 9001)
InfraServ Gendorf		
Tel.: +49 8679 7 5599	
Fax: +49 8679 7 39 5599
Mobiltel.: +49 172 8649205
E-Mail: Stefan.Gasteiger@gendorf.de




> -----Original Message-----
> From: Foster, Kristopher [mailto:KFoster@C1Communications.com]
> Sent: Monday, May 29, 2000 3:44 AM
> To: '6bone@isi.edu'
> Subject: IPv6 over IPv4 tunnels in IOS
> 
> 
> I have been searching for tunneling examples on the Cisco 
> platform.  So far
> my attempts at configuring our tunnel have not been 
> successful, any help
> would be appreciated.
> 
> Sincerely,
> Kristopher K. Foster
> Technologist
> C1 Communications
> http://www.c1communications.com
> office: 905/814-3320
> cell: 416/728-2763
>