[6bone] ping6

Nicolas DEFFAYET nicolas.deffayet@ndsoftware.net
23 Aug 2002 17:45:13 +0200


On Fri, 2002-08-23 at 16:35, Gino Francisco Alania Hurtado wrote:
> Desire to do ping6 from host of my LAN Ipv6 to www.6bone.net , analyzing 
> zebra I observe this: 
> 
> 
> inter2> show bgp summary
> BGP router identifier 200.60.172.144, local AS number 46014
> 1 BGP AS-PATH entries
> 0 BGP community entries
> 
> Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  
> State/* PfxRcd*
> 3ffe:8070:101a::1
>                 4   278       7       7        0    0    0 00:01:53 
> *Idle  *     
> 
> Total number of neighbors 1

   Autonomous System Name: IANA-RSVD
   Autonomous System Block: 32768 - 64511

First don't use reserved AS, if you don't have your AS, use a private
ASN.

> 
> The problem where is in my end or the remote end?

Ask UNAM for check, UNAM must have:
neighbor 3ffe:8070:101a::2 remote-as 46014

> I have the following configuration of zebra
> -------------------------------------------------------------------------------------------------------------------------
> interface eth0
>  ipv6 nd send-ra
>  ipv6 nd prefix-advertisement 3ffe:8070:101a:1001::/64
> !
> interface inter2
> --------------------------------------------------------------------------------------------------------------------------
> 
> and in the BGP he is the following one.
> 
> --------------------------------------------------------------------------------------------------------------
> router bgp 46014
> !! bgp router-id 6342
>  ipv6 bgp network 3ffe:8070:101a::/48
> !nuevo tunnel unam
>  ipv6 bgp neighbor 3ffe:8070:101a::1 remote-as 278
>  ipv6 bgp neighbor 3ffe:8070:101a::1 interface inter2
>  ipv6 bgp neighbor 3ffe:8070:101a::1 description UNAM mexico 6bone
>  ipv6 bgp neighbor 3ffe:8070:101a::1 next-hop-self
> !
> access-list all permit any
> !
> line vty
> -----------------------------------------------------------------------------------------------------------------

Configuration not very good.

Install Zebra 0.93a and use:

!
! Zebra configuration saved from vty
!   2001/08/11 12:37:58
!
hostname !!!-your-hostname-!!!
password !!!-password-!!!!
enable password !!!-password-!!!
!
log file /var/log/bgpd.log
!
debug bgp events
!
router bgp 46014
 bgp router-id 200.60.172.144
 !
 neighbor 3ffe:8070:101a::1 remote-as 278
 neighbor 3ffe:8070:101a::1 next-hop-self
 neighbor 3ffe:8070:101a::1 interface inter2
 neighbor 3ffe:8070:101a::1 description UNAM
!
 address-family ipv6
  network 3ffe:8070:101a::/48
  neighbor 3ffe:8070:101a::1 activate
  neighbor 3ffe:8070:101a::1 soft-reconfiguration inbound
  neighbor 3ffe:8070:101a::1 route-map unam-out out
 exit-address-family
!
ipv6 access-list all permit any
!
route-map unam-out permit 10
 match ipv6 address all
 set ipv6 next-hop global 3ffe:8070:101a::2
!
line vty
 exec-timeout 60 0
!
end

You can add after filter for accept only pTLA and sTLA from your peer.

Best Regards,

Nicolas DEFFAYET