routing question

Richardson, Jeremy (LNG) jeremy.richardson@lexis-nexis.com
Thu, 29 Mar 2001 13:40:18 -0500


This message is in MIME format. Since your mail reader does not understand
this format, some or all of this message may not be legible.

------_=_NextPart_001_01C0B87F.B7E90CF8
Content-Type: text/plain;
	charset="iso-8859-1"

Each router will need two static routes.  If these are Cisco IOS routers,
you can cut and paste the two lines that appear under "RouterX's statics
routes" to each of the respective routers.  I tried this in the lab, so I
know it works.  If you stare at it long enough, it makes some sense.  

After pasting the routes, compare each router's routing table to this
message, they should be the same:

              0/0        0/1 
RouterA 10.2.3.1   10.5.4.1 
RouterB 10.2.4.1   10.2.3.2 
RouterC 10.6.2.1   10.2.4.2 
RouterD 10.5.4.2   10.6.2.2<?xml:namespace prefix = o ns =
"urn:schemas-microsoft-com:office:office" /> 
(assuming 24 bit subnet mask & Ethernet Interfaces)
10.2.3.0 = Routers A & B
10.5.4.0 = Routers A & D
10.2.4.0 = Routers B & C
10.6.2.0 = Routers C & D

RouterA's directly connected routes 
(shown in routing table, but not configured):
C 10.2.3.0 255.255.255.0 Ethernet0/0
C 10.5.4.0 255.255.255.0 Ethernet0/1
RouterA's static Routes:
ip route 10.2.4.0 225.255.255.0 Ethernet0/0
ip route 10.6.2.0 255.255.255.0 Ethernet0/1

RouterB's directly connected routes 
C 10.2.4.0 255.255.255.0 Ethernet0/0
C 10.2.3.0 255.255.255.0 Ethernet0/1
RouterB's static Routes:
ip route 10.6.2.0 225.255.255.0 Ethernet0/0
ip route 10.5.4.0 255.255.255.0 Ethernet0/1

RouterC's directly connected routes 
C 10.6,2.0 255.255.255.0 Ethernet0/0
C 10.2.4.0 255.255.255.0 Ethernet 0/1
RouterC's static Routes:
ip route 10.5.4.0 225.255.255.0 Ethernet0/0
ip route 10.2.3.0 255.255.255.0 Ethernet0/1

RouterD's directly connected routes 
C 10.5.4.0 255.255.255.0 Ethernet0/0
C 10.6.2.0 255.255.255.0 Ethernet 0/1
RouterD's static Routes:
ip route 10.2.3.0 225.255.255.0 Ethernet0/0
ip route 10.2.4.0 255.255.255.0 Ethernet0/1


 
I highly recommend a routing protocol, unless this is an excercise in static
routes. Use the following config commands on all routers, for RIP II:
router rip
  network 10.0.0.0
  version 2
 
For EIGRP:
router eigrp 1
   network 10.0.0.0
 
For OSPF:
router ospf 1
   network 10.0.0.0 0.255.255.255 area 0
 
Again, use the same configuration on each router.  The end result is the
same, and it's much easier (and dynamic).
 
Hope this helps...
 
Jeremy Richardson
 

 

 

 
 
 -----Original Message-----
From: Nathaniel Clifton [mailto:nclifton@ncren.net]
Sent: Wednesday, March 28, 2001 12:40 PM
To: 6bone@isi.edu
Subject: routing question


  
Guys, 

I need some help with the following scenario: 


4 routers with 2 interfaces each 0/0 and 0/1 and all of them need to talk to
one another 


ip addresses: 


0/0                                        0/1 
10.2.3.1                                10.5.4.1 
10.2.4.1                                10.2.3.2 
10.6.2.1                                10.2.4.2 
10.5.4.2                                10.6.2.2 


I need help figuring out how the static routes would be configured..... 


Thanks in advance..... 
  


Nate 
P.S. This question is for an IPv6 project 


------_=_NextPart_001_01C0B87F.B7E90CF8
Content-Type: text/html;
	charset="iso-8859-1"

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN">
<HTML><HEAD>
<META HTTP-EQUIV="Content-Type" CONTENT="text/html; charset=iso-8859-1">


<META content="MSHTML 5.00.3103.1000" name=GENERATOR></HEAD>
<BODY><FONT face=Arial>
<P class=MsoNormal><FONT color=#0000ff size=2><SPAN 
class=908311018-29032001>Each router&nbsp;will need two static routes.&nbsp; If 
these are Cisco IOS routers, you can cut and paste the two lines that appear 
under "<U>RouterX's statics routes</U>" to each of the respective routers.&nbsp; 
I&nbsp;tried this in the lab, so I know it works.&nbsp; If you stare at it long 
enough, it makes some sense.&nbsp; </SPAN></FONT></P>
<P class=MsoNormal><FONT color=#0000ff size=2><SPAN 
class=908311018-29032001>After pasting the routes, compare each router's routing 
table to this message, they should be the same:</SPAN></FONT></P>
<P class=MsoNormal><FONT color=#0000ff size=2><SPAN 
class=908311018-29032001><FONT face=Tahoma><FONT face=Arial><FONT 
face=Arial><FONT color=#0000ff><FONT size=2><EM><SPAN><SPAN 
style="mso-spacerun: yes"><STRONG><SPAN 
class=908311018-29032001>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</SPAN>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; 
</STRONG></SPAN><U><STRONG>0/0</STRONG></U></FONT><FONT 
color=#0000ff></EM></FONT><EM><FONT 
size=2>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;<B><U>0/1</U></B> 
<BR>Router<STRONG>A</STRONG> 10.2.3.1&nbsp;&nbsp;&nbsp;10.5.4.1 
<BR>Router<STRONG>B</STRONG> 10.2.4.1&nbsp;&nbsp;&nbsp;10.2.3.2 
<BR>Router<STRONG>C</STRONG> 10.6.2.1&nbsp;&nbsp;&nbsp;10.2.4.2 
<BR>Router<STRONG>D</STRONG> 10.5.4.2&nbsp;&nbsp;&nbsp;10.6.2.2<?xml:namespace 
prefix = o ns = "urn:schemas-microsoft-com:office:office" 
/><o:p></o:p></FONT></EM></FONT></SPAN><EM><FONT color=#0000ff size=2> 
<BR></FONT></EM></FONT></FONT></FONT></SPAN></FONT><FONT color=#0000ff 
size=2><SPAN class=908311018-29032001><EM><FONT size=2><FONT color=#0000ff><SPAN 
style="FONT-FAMILY: 'Courier New'"><EM>(assuming 24 bit subnet mask &amp; 
Ethernet Interfaces)<BR></EM></SPAN></FONT></FONT></EM></SPAN></FONT><FONT 
color=#0000ff size=2><SPAN class=908311018-29032001><EM><FONT 
color=#0000ff><FONT size=2><EM><SPAN style="FONT-FAMILY: 'Courier New'">10.2.3.0 
= Routers A &amp; B</SPAN><SPAN 
style="FONT-FAMILY: 'Courier New'"></EM></FONT></FONT><BR><EM><FONT 
color=#0000ff size=2>10.5.4.0 = Routers A &amp; D<BR></FONT></EM></SPAN><FONT 
size=2><FONT color=#0000ff><EM><SPAN style="FONT-FAMILY: 'Courier New'">10.2.4.0 
= Routers B &amp; C<BR></SPAN><SPAN style="FONT-FAMILY: 'Courier New'">10.6.2.0 
= Routers C &amp; D<o:p></o:p></SPAN></EM></FONT></FONT></EM></SPAN></FONT></P>
<P class=MsoNormal><FONT face="Courier New"><FONT color=#0000ff><FONT 
size=2><STRONG>RouterA&#8217;s directly connected routes <BR></STRONG><SPAN 
style="FONT-FAMILY: 'Courier New'"></FONT></FONT></FONT><EM><FONT color=#0000ff 
size=2>(shown in routing table, but not configured):<BR></FONT></EM></SPAN><FONT 
color=#0000ff><FONT size=2><SPAN style="FONT-FAMILY: 'Courier New'"><SPAN 
class=908311018-29032001>C </SPAN>10.2.3.0 255.255.255.0 
Ethernet0/0<BR></SPAN><SPAN 
style="FONT-FAMILY: 'Courier New'"></FONT></FONT><FONT size=2><FONT 
color=#0000ff><SPAN class=908311018-29032001>C </SPAN>10.5.4.0 255.255.255.0 
Ethernet0/1<BR></FONT></FONT></SPAN><FONT color=#0000ff><FONT size=2><B><SPAN 
style="FONT-FAMILY: 'Courier New'">RouterA&#8217;s static Routes:<BR></SPAN></B><SPAN 
style="FONT-FAMILY: 'Courier New'"></FONT></FONT><FONT color=#0000ff size=2>ip 
route 10.2.4.0 225.255.255.0 Ethernet0/0<BR></FONT></SPAN><FONT color=#0000ff 
size=2><SPAN style="FONT-FAMILY: 'Courier New'">ip route 10.6.2.0 255.255.255.0 
Ethernet0/1</SPAN></FONT></P>
<P class=MsoNormal><SPAN style="FONT-FAMILY: 'Courier New'"><FONT 
color=#0000ff><FONT size=2><STRONG>Router<SPAN 
class=908311018-29032001>B</SPAN>&#8217;s directly connected routes 
<BR></STRONG></FONT></FONT><FONT color=#0000ff><FONT size=2><SPAN 
style="FONT-FAMILY: 'Courier New'"><SPAN class=908311018-29032001>C 
</SPAN>10.2.<SPAN class=908311018-29032001>4</SPAN>.0 255.255.255.0 
Ethernet0/0<BR></SPAN><SPAN 
style="FONT-FAMILY: 'Courier New'"></FONT></FONT><FONT size=2><FONT 
color=#0000ff><SPAN class=908311018-29032001>C </SPAN>10.<SPAN 
class=908311018-29032001>2</SPAN>.<SPAN class=908311018-29032001>3</SPAN>.0 
255.255.255.0 Ethernet0/1<BR></FONT></FONT></SPAN><FONT color=#0000ff><FONT 
size=2><B><SPAN style="FONT-FAMILY: 'Courier New'">Router<SPAN 
class=908311018-29032001>B</SPAN>&#8217;s static Routes:<BR></SPAN></B><SPAN 
style="FONT-FAMILY: 'Courier New'"></FONT></FONT><FONT color=#0000ff size=2>ip 
route 10.<SPAN class=908311018-29032001>6.2</SPAN>.0 225.255.255.0 
Ethernet0/0<BR></FONT></SPAN><FONT color=#0000ff size=2><SPAN 
style="FONT-FAMILY: 'Courier New'">ip route 10.<SPAN 
class=908311018-29032001>5.4</SPAN>.0 255.255.255.0 
Ethernet0/1</SPAN></FONT></SPAN></P>
<P class=MsoNormal><SPAN style="FONT-FAMILY: 'Courier New'"><SPAN 
style="FONT-FAMILY: 'Courier New'"><FONT color=#0000ff><FONT 
size=2><STRONG>Router<SPAN class=908311018-29032001>C</SPAN>&#8217;s directly 
connected routes <BR></STRONG></FONT></FONT><FONT color=#0000ff><FONT 
size=2><SPAN style="FONT-FAMILY: 'Courier New'"><SPAN class=908311018-29032001>C 
</SPAN>10.<SPAN class=908311018-29032001>6,2</SPAN>.0 255.255.255.0 
Ethernet0/0<BR></SPAN><SPAN 
style="FONT-FAMILY: 'Courier New'"></FONT></FONT><FONT size=2><FONT 
color=#0000ff><SPAN class=908311018-29032001>C </SPAN>10.<SPAN 
class=908311018-29032001>2.4</SPAN>.0 255.255.255.0 Ethernet 
0/1<BR></FONT></FONT></SPAN><FONT color=#0000ff><FONT size=2><B><SPAN 
style="FONT-FAMILY: 'Courier New'">Router<SPAN 
class=908311018-29032001>C</SPAN>&#8217;s static Routes:<BR></SPAN></B><SPAN 
style="FONT-FAMILY: 'Courier New'"></FONT></FONT><FONT color=#0000ff size=2>ip 
route 10.<SPAN class=908311018-29032001>5.4</SPAN>.0 225.255.255.0 
Ethernet0/0<BR></FONT></SPAN><FONT color=#0000ff size=2><SPAN 
style="FONT-FAMILY: 'Courier New'">ip route 10.<SPAN 
class=908311018-29032001>2.3</SPAN>.0 255.255.255.0 
Ethernet0/1</SPAN></FONT></SPAN></SPAN></P>
<P class=MsoNormal><SPAN style="FONT-FAMILY: 'Courier New'"><SPAN 
style="FONT-FAMILY: 'Courier New'"><SPAN 
style="FONT-FAMILY: 'Courier New'"><FONT color=#0000ff><FONT 
size=2><STRONG>Router<SPAN class=908311018-29032001>D</SPAN>&#8217;s directly 
connected routes <BR></STRONG></FONT></FONT><FONT color=#0000ff><FONT 
size=2><SPAN style="FONT-FAMILY: 'Courier New'"><SPAN class=908311018-29032001>C 
</SPAN>10.<SPAN class=908311018-29032001>5.4</SPAN>.0 255.255.255.0 
Ethernet0/0<BR></SPAN><SPAN 
style="FONT-FAMILY: 'Courier New'"></FONT></FONT><FONT size=2><FONT 
color=#0000ff><SPAN class=908311018-29032001>C </SPAN>10.<SPAN 
class=908311018-29032001>6.2</SPAN>.0 255.255.255.0 Ethernet 
0/1<BR></FONT></FONT></SPAN><FONT color=#0000ff><FONT size=2><B><SPAN 
style="FONT-FAMILY: 'Courier New'">Router<SPAN 
class=908311018-29032001>D</SPAN>&#8217;s static Routes:<BR></SPAN></B><SPAN 
style="FONT-FAMILY: 'Courier New'"></FONT></FONT><FONT color=#0000ff size=2>ip 
route 10.<SPAN class=908311018-29032001>2.3</SPAN>.0 225.255.255.0 
Ethernet0/0<BR></FONT></SPAN><FONT size=2><FONT color=#0000ff><SPAN 
style="FONT-FAMILY: 'Courier New'">ip route 10.<SPAN 
class=908311018-29032001>2.4</SPAN>.0 255.255.255.0 
Ethernet0/1<o:p></o:p></SPAN><o:p></o:p></FONT></FONT></SPAN><o:p></o:p></SPAN></SPAN></FONT><FONT 
face=Tahoma><BR></P>
<DIV>&nbsp;</DIV>
<DIV><FONT color=#0000ff face=Arial size=2><SPAN class=908311018-29032001>I 
highly recommend a routing protocol, unless this is an excercise in static 
routes. Use the following config commands on all routers, for RIP 
II:</SPAN></FONT></DIV>
<DIV><STRONG><FONT color=#0000ff face=Arial size=2><SPAN 
class=908311018-29032001>router rip</SPAN></FONT></STRONG></DIV>
<DIV><STRONG><FONT color=#0000ff face=Arial size=2><SPAN 
class=908311018-29032001>&nbsp;  network 10.0.0.0</SPAN></FONT></STRONG></DIV>
<DIV><FONT color=#0000ff face=Arial size=2><SPAN 
class=908311018-29032001><STRONG>&nbsp;  version 2</STRONG></SPAN></FONT></DIV>
<DIV><FONT color=#0000ff face=Arial size=2><SPAN 
class=908311018-29032001></SPAN></FONT>&nbsp;</DIV>
<DIV><FONT color=#0000ff face=Arial size=2><SPAN class=908311018-29032001>For 
EIGRP:</SPAN></FONT></DIV>
<DIV><STRONG><FONT color=#0000ff face=Arial size=2><SPAN 
class=908311018-29032001>router eigrp 1</SPAN></FONT></STRONG></DIV>
<DIV><FONT color=#0000ff face=Arial size=2><SPAN 
class=908311018-29032001><STRONG>&nbsp; &nbsp;network 
10.0.0.0</STRONG></SPAN></FONT></DIV>
<DIV><FONT color=#0000ff face=Arial size=2><SPAN 
class=908311018-29032001></SPAN></FONT>&nbsp;</DIV>
<DIV><FONT color=#0000ff face=Arial size=2><SPAN class=908311018-29032001>For 
OSPF:</SPAN></FONT></DIV>
<DIV><STRONG><FONT color=#0000ff face=Arial size=2><SPAN 
class=908311018-29032001>router ospf 1</SPAN></FONT></STRONG></DIV>
<DIV><FONT color=#0000ff face=Arial size=2><SPAN 
class=908311018-29032001><STRONG>&nbsp;&nbsp; network 10.0.0.0 0.255.255.255 
area 0</STRONG></SPAN></FONT></DIV>
<DIV><FONT color=#0000ff face=Arial size=2><SPAN 
class=908311018-29032001></SPAN></FONT>&nbsp;</DIV>
<DIV><FONT color=#0000ff face=Arial size=2><SPAN class=908311018-29032001>Again, 
use the same configuration on each router.&nbsp; The end result is the same, and 
it's much easier (and dynamic).</SPAN></FONT></DIV>
<DIV><FONT color=#0000ff face=Arial size=2><SPAN 
class=908311018-29032001></SPAN></FONT>&nbsp;</DIV>
<DIV><FONT color=#0000ff face=Arial size=2><SPAN class=908311018-29032001>Hope 
this helps...</SPAN></FONT></DIV>
<DIV><FONT color=#0000ff face=Arial size=2><SPAN 
class=908311018-29032001></SPAN></FONT>&nbsp;</DIV>
<DIV><FONT color=#0000ff face=Arial size=2><SPAN class=908311018-29032001>Jeremy 
Richardson</SPAN></FONT></DIV>
<DIV><FONT color=#0000ff face=Arial size=2><SPAN 
class=908311018-29032001></SPAN></FONT>&nbsp;</DIV></FONT><FONT face=Tahoma>
<DIV></FONT>
<P class=MsoNormal><FONT face=Tahoma></FONT>&nbsp;</P>
<P class=MsoNormal><FONT face=Tahoma>&nbsp;</P></FONT><FONT face=Tahoma><FONT 
size=2><SPAN class=908311018-29032001></SPAN></FONT></FONT></DIV>
<BLOCKQUOTE style="MARGIN-RIGHT: 0px">
  <DIV align=left class=OutlookMessageHeader dir=ltr><FONT face=Tahoma><FONT 
  size=2><SPAN class=908311018-29032001></SPAN></FONT></FONT>&nbsp;</DIV>
  <DIV align=left class=OutlookMessageHeader dir=ltr><FONT face=Tahoma><FONT 
  size=2><SPAN class=908311018-29032001></SPAN></FONT></FONT>&nbsp;</DIV>
  <DIV align=left class=OutlookMessageHeader dir=ltr><FONT face=Tahoma><FONT 
  size=2><SPAN class=908311018-29032001>&nbsp;</SPAN>-----Original 
  Message-----<BR><B>From:</B> Nathaniel Clifton 
  [mailto:nclifton@ncren.net]<BR><B>Sent:</B> Wednesday, March 28, 2001 12:40 
  PM<BR><B>To:</B> 6bone@isi.edu<BR><B>Subject:</B> routing 
  question<BR><BR></DIV></FONT></FONT>&nbsp; <BR>Guys, 
  <P>I need some help with the following scenario: 
  <P><B>4 routers</B> with <B>2 interfaces</B> each <B>0/0</B> and <B>0/1</B> 
  and all of them need to talk to one another 
  <P>ip addresses: 
  <P><B><U>0/0</U></B>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; 
  <B><U>0/1</U></B> 
  <BR>10.2.3.1&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; 
  10.5.4.1 
  <BR>10.2.4.1&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; 
  10.2.3.2 
  <BR>10.6.2.1&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; 
  10.2.4.2 
  <BR>10.5.4.2&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; 
  10.6.2.2 
  <P>I need help figuring out how the static routes would be configured..... 
  <P>Thanks in advance..... <BR>&nbsp; 
  <P>Nate <BR>P.S. This question is for an IPv6 project 
</P></BLOCKQUOTE></BODY></HTML>

------_=_NextPart_001_01C0B87F.B7E90CF8--