Tunnel in cisco router.

Mithrandir mithrandir@skynet.be
Fri, 29 Dec 2000 14:47:16 +0100


Okay this is one out of a lot of try outs.

Don't shoot me I just use this in a Closed LAN environment.

It does not work. (Pinging that is)

Router#show config
Using 826 out of 32762 bytes
!
version 11.3
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Router
!
!
ipv6 unicast-routing
!
!
!
interface Tunnel0
 ip unnumbered Ethernet0
 ip mtu 1480
 ipv6 enable
 ipv6 unnumbered Ethernet0
 tunnel source Ethernet0
 tunnel destination 128.127.1.1
 tunnel mode ipv6ip
!
interface Ethernet0
 ip address 192.168.1.94 255.255.255.0
 no ip directed-broadcast
 ipv6 enable
 ipv6 address 3FFE:2501:200:3::1/64
!
interface Serial0
 ip address 128.127.1.2 255.255.255.0
 no ip directed-broadcast
 clockrate 64000
!
ip classless
!
ipv6 route 3FFE::0/16 Tunnel0
!
line con 0
 transport input none
line aux 0
line vty 0 4
 login
!
end

Router#show ip int brief
Interface              IP-Address      OK? Method Status
Protocol

Ethernet0              192.168.1.94    YES manual up                    up

Serial0                128.127.1.2     YES NVRAM  up                    up

Tunnel0                192.168.1.94    YES unset  up                    up

Router#

Router#show ipv6 int
Ethernet0 is up, line protocol is up
  IPv6 is enabled, link-local address is FE80::2E0:B0FF:FE55:C64F
  Global unicast address(es):
    3FFE:2501:200:3::1, subnet is 3FFE:2501:200:3::0/64
  Joined group address(es):
    FF02::1
    FF02::2
    FF02::1:FF55:C64F
    FF02::1:FF00:1
  MTU is 1500 bytes
  ICMP error messages limited to one every 500 milliseconds
  ND advertised reachable time is 0 milliseconds
  ND advertised retransmit interval is 0 milliseconds
  ND router advertisements are sent every 200 seconds
  ND router advertisements live for 1800 seconds
  Hosts use stateless autoconfig for addresses.
Tunnel0 is up, line protocol is up
  IPv6 is enabled, link-local address is FE80::E0:B055:C64F:8
  Interface is unnumbered. Using address of Ethernet0
    Address is 3FFE:2501:200:3::1
  Joined group address(es):
    FF02::1
    FF02::2
    FF02::1:FF4F:8
  MTU is 1480 bytes
  ICMP error messages limited to one every 500 milliseconds
  ND advertised reachable time is 0 milliseconds
  ND advertised retransmit interval is 0 milliseconds
  ND router advertisements are sent every 200 seconds
  ND router advertisements live for 1800 seconds
  Hosts use stateless autoconfig for addresses.
Router#

bugs#show config
Using 865 out of 32762 bytes
!
version 11.3
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname bugs
!
enable secret .
enable password 
!
ipv6 unicast-routing
!
!
!
interface Tunnel0
 ip unnumbered Ethernet0
 ip mtu 1480
 no ip mroute-cache
 ipv6 enable
 ipv6 unnumbered Ethernet0
 tunnel source Ethernet0
 tunnel destination 128.127.1.2
 tunnel mode ipv6ip
!
interface Ethernet0
 ip address 192.168.1.95 255.255.255.0
 ipv6 enable
 ipv6 address 3FFE:2501:200:3::1/64
 no cdp enable
!
interface Serial0
 ip address 128.127.1.1 255.255.255.0
 no fair-queue
!
no ip classless
!
ipv6 route 3FFE::0/16 Tunnel0
!
line con 0
 exec-timeout 0 0
line aux 0
line vty 0 4
 password bugs
 login
!
end

bugs#show ip int brief
Interface              IP-Address      OK? Method Status
Protocol

Ethernet0              192.168.1.95    YES NVRAM  up                    up

Serial0                128.127.1.1     YES NVRAM  up                    up

Tunnel0                192.168.1.95    YES unset  up                    up

bugs#

bugs#show ipv6 int
Ethernet0 is up, line protocol is up
  IPv6 is enabled, link-local address is FE80::210:7BFF:FE36:AD63
  Global unicast address(es):
    3FFE:2501:200:3::1, subnet is 3FFE:2501:200:3::0/64
  Joined group address(es):
    FF02::1
    FF02::2
    FF02::1:FF36:AD63
    FF02::1:FF00:1
  MTU is 1500 bytes
  ICMP error messages limited to one every 500 milliseconds
  ND advertised reachable time is 0 milliseconds
  ND advertised retransmit interval is 0 milliseconds
  ND router advertisements are sent every 200 seconds
  ND router advertisements live for 1800 seconds
  Hosts use stateless autoconfig for addresses.
Tunnel0 is up, line protocol is up
  IPv6 is enabled, link-local address is FE80::10:7B36:AD63:8
  Interface is unnumbered. Using address of Ethernet0
    Address is 3FFE:2501:200:3::1
  Joined group address(es):
    FF02::1
    FF02::2
    FF02::1:FF63:8
  MTU is 1480 bytes
  ICMP error messages limited to one every 500 milliseconds
  ND advertised reachable time is 0 milliseconds
  ND advertised retransmit interval is 0 milliseconds
  ND router advertisements are sent every 200 seconds
  ND router advertisements live for 1800 seconds
  Hosts use stateless autoconfig for addresses.
bugs#